Тема: Помилка при запуску skype на linux fedora

Завжди, коли ставлю скайп на лінуксі, постійно якісь проблеми.
Але раніше, всі вони вирішувалися встановлення додаткових залежностей, а зараз вже походу щось серйозніше.
Одним словом, робив все, по цій інструкції: http://www.if-not-true-then-false.com/2 … -linux-sl/
Пробую запустити, а воно каже:

/usr/bin/skype: /opt/skype/skype: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

Прочитав, що треба ще доставити пакунок glib чи якось так. Ну які тільки не ставив, далі та сама помилка.
Може хтось зустрічався з подібним ? Підкажіть будь ласка.

2

Re: Помилка при запуску skype на linux fedora

а що

yum whatprovides \*lib/ld-linux.so.2

каже?

Re: Помилка при запуску skype на linux fedora

koala написав:

а що

yum whatprovides \*lib/ld-linux.so.2

каже?

Каже таке:

glibc-2.16-24.fc18.i686 : The GNU libc libraries
Сховище     : fedora
Відповідність:
Назва файла : /lib/ld-linux.so.2



glibc-2.16-34.fc18.i686 : The GNU libc libraries
Сховище     : updates
Відповідність:
Назва файла : /lib/ld-linux.so.2

Коли ставлю пакунок glibc-2.16-24.fc18:

Пакунок glibc-2.16-24.fc18.x86_64 вже встановлено, його версія є найсвіжішою

А коли glibc-2.16-34.fc18:

Помилка під час перевірки операції:
  file /usr/lib64/audit from install of glibc-2.16-34.fc18.x86_64 conflicts with file from package audit-2.2.1-2.fc18.x86_64

4

Re: Помилка при запуску skype на linux fedora

uname -a

будь ласка.
Бо система у вас, як я розумію, не тієї бітності.
А вам буде краще скачати пакунок для Fedora 16 з офсайту.

Re: Помилка при запуску skype на linux fedora

koala написав:
uname -a

будь ласка.
Бо система у вас, як я розумію, не тієї бітності.
А вам буде краще скачати пакунок для Fedora 16 з офсайту.

Linux 192.168.1.3 3.6.10-4.fc18.x86_64 #1 SMP Tue Dec 11 18:01:27 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

6

Re: Помилка при запуску skype на linux fedora

Ну правильно, у вас x86_64, тому, щоб самому налаштувати правильні пакети, треба ... гм... трохи попрацювати. Ставте офіційний.

7 Востаннє редагувалося HetmanNet (26.03.2014 02:08:03)

Re: Помилка при запуску skype на linux fedora

Ця інструкція досі працює :)

Віддамся на один вечір в хороші дівочі руки.. не дорого, в у.о. .. Якщо сподобається, то залишуся безкоштовно назавжди..

Re: Помилка при запуску skype на linux fedora

HetmanNet написав:

Ця інструкція досі працює :)

Вибиває така помилка:

error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory

Проте пакунок, який містить цю бібліотеку - стоїть.

9

Re: Помилка при запуску skype на linux fedora

Значить бібліотека знаходиться не там, де треба. Потрібно лише скопіювати (створити символічне посилання) в загальний каталог динамічних бібліотек.

Говорила баба діду: «Я поїду к Білодіду, Ізучу двомовну мову І вернусь обратно знову». А дід бабі: «Не *изди, К Білодіду нєт їзди, — Туди не ходять поїзди»

10

Re: Помилка при запуску skype на linux fedora

0xDADA11C7 написав:

Значить бібліотека знаходиться не там, де треба. Потрібно лише скопіювати (створити символічне посилання) в загальний каталог динамічних бібліотек.

Так і зробив, тепер помилка:

error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64

11 Востаннє редагувалося koala (27.03.2014 22:36:35)

Re: Помилка при запуску skype на linux fedora

А що з офіційним rpm-ом?

12

Re: Помилка при запуску skype на linux fedora

Hanter написав:
0xDADA11C7 написав:

Значить бібліотека знаходиться не там, де треба. Потрібно лише скопіювати (створити символічне посилання) в загальний каталог динамічних бібліотек.

Так і зробив, тепер помилка:

error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64

Ти скопіював(створив символічне посилання) 64-бітної версії бібліотеки. Після всіх тих встановлень має бути така ж але 32-бітна. От на неї і треба зробити символічне посилання.

Нехай буде з тобою сила!

13

Re: Помилка при запуску skype на linux fedora

Цікавості заради завантажив собі на віртуалку Fedora x86_64-20-1 з оф. сайту.
Далі дві команди (Капітан Очевидність змушує сказати, що з терміналу під root-ом):

curl -O http://download.skype.com/linux/skype-4.2.0.13-fedora.i586.rpm
yum install skype-4.2.0.13-fedora.i586.rpm

Там, щоправда, 236 пакунків залежностей на 140 МБ, але то вже звиняйте, і у вас мало ставитися, і, власне, це ви і намагалися ручками зробити.
А далі - не повірите - ВСЕ ПРАЦЮЄ!

14

Re: Помилка при запуску skype на linux fedora

koala написав:

Цікавості заради завантажив собі на віртуалку Fedora x86_64-20-1 з оф. сайту.
Далі дві команди (Капітан Очевидність змушує сказати, що з терміналу під root-ом):

curl -O http://download.skype.com/linux/skype-4.2.0.13-fedora.i586.rpm
yum install skype-4.2.0.13-fedora.i586.rpm

Там, щоправда, 236 пакунків залежностей на 140 МБ, але то вже звиняйте, і у вас мало ставитися, і, власне, це ви і намагалися ручками зробити.
А далі - не повірите - ВСЕ ПРАЦЮЄ!

Проблема у наступному   :(

--> Визначення залежностей завершено
Помилка:  Multilib version problems found. This often means that the root
         cause is something else and multilib version checking is just
         pointing out that there is a problem. Eg.:
         
           1. You have an upgrade for libdrm which is missing some
              dependency that another package requires. Yum is trying to
              solve this by installing an older version of libdrm of the
              different architecture. If you exclude the bad architecture
              yum will tell you what the root cause is (which package
              requires what). You can try redoing the upgrade with
              --exclude libdrm.otherarch ... this should give you an error
              message showing the root cause of the problem.
         
           2. You have multiple architectures of libdrm installed, but
              yum can only see an upgrade for one of those arcitectures.
              If you don't want/need both architectures anymore then you
              can remove the one with the missing update and everything
              will work.
         
           3. You have duplicate versions of libdrm installed already.
              You can use "yum check" to get yum show these errors.
         
         ...you can also use --setopt=protected_multilib=false to remove
         this checking, however this is almost never the correct thing to
         do as something else is very likely to go wrong (often causing
         much more problems).
         
         Захищені версії multilib: libdrm-2.4.46-1.fc18.i686 != libdrm-2.4.40-1.fc18.x86_64
Помилка: Захищені версії multilib: mesa-libglapi-9.2-0.12.20130610.fc18.i686 != mesa-libglapi-9.0.1-1.fc18.x86_64
Помилка: Захищені версії multilib: libuuid-2.22.2-7.fc18.i686 != libuuid-2.22.1-2.1.fc18.x86_64
Помилка: Захищені версії multilib: libXxf86vm-1.1.2-5.20130524git4c4123441.fc18.i686 != libXxf86vm-1.1.2-2.fc18.x86_64
Помилка: Захищені версії multilib: libblkid-2.22.2-7.fc18.i686 != libblkid-2.22.1-2.1.fc18.x86_64

15

Re: Помилка при запуску skype на linux fedora

Звісно, бо ви понавстановлювали купу невідомо чого, а тепер маєте клопіт. Видаліть бібліотеки, згадані в помилках (тільки дивіться уважно, може, ще щось від них залежить) і повторіть встановлення.

16

Re: Помилка при запуску skype на linux fedora

koala написав:

Цікавості заради завантажив собі на віртуалку Fedora x86_64-20-1 з оф. сайту.
Далі дві команди (Капітан Очевидність змушує сказати, що з терміналу під root-ом):

curl -O http://download.skype.com/linux/skype-4.2.0.13-fedora.i586.rpm
yum install skype-4.2.0.13-fedora.i586.rpm

Там, щоправда, 236 пакунків залежностей на 140 МБ, але то вже звиняйте, і у вас мало ставитися, і, власне, це ви і намагалися ручками зробити.
А далі - не повірите - ВСЕ ПРАЦЮЄ!

Проблема у наступному   :(

--> Визначення залежностей завершено
Помилка:  Multilib version problems found. This often means that the root
         cause is something else and multilib version checking is just
         pointing out that there is a problem. Eg.:
         
           1. You have an upgrade for libdrm which is missing some
              dependency that another package requires. Yum is trying to
              solve this by installing an older version of libdrm of the
              different architecture. If you exclude the bad architecture
              yum will tell you what the root cause is (which package
              requires what). You can try redoing the upgrade with
              --exclude libdrm.otherarch ... this should give you an error
              message showing the root cause of the problem.
         
           2. You have multiple architectures of libdrm installed, but
              yum can only see an upgrade for one of those arcitectures.
              If you don't want/need both architectures anymore then you
              can remove the one with the missing update and everything
              will work.
         
           3. You have duplicate versions of libdrm installed already.
              You can use "yum check" to get yum show these errors.
         
         ...you can also use --setopt=protected_multilib=false to remove
         this checking, however this is almost never the correct thing to
         do as something else is very likely to go wrong (often causing
         much more problems).
         
         Захищені версії multilib: libdrm-2.4.46-1.fc18.i686 != libdrm-2.4.40-1.fc18.x86_64
Помилка: Захищені версії multilib: mesa-libglapi-9.2-0.12.20130610.fc18.i686 != mesa-libglapi-9.0.1-1.fc18.x86_64
Помилка: Захищені версії multilib: libuuid-2.22.2-7.fc18.i686 != libuuid-2.22.1-2.1.fc18.x86_64
Помилка: Захищені версії multilib: libXxf86vm-1.1.2-5.20130524git4c4123441.fc18.i686 != libXxf86vm-1.1.2-2.fc18.x86_64
Помилка: Захищені версії multilib: libblkid-2.22.2-7.fc18.i686 != libblkid-2.22.1-2.1.fc18.x86_64

17

Re: Помилка при запуску skype на linux fedora

А взагалі, знаєте, якщо хочете вручну пакети ставити - то ставте собі якийсь KISS-дистибутив, LFS(жартую), Arch, Slackware...