1

Тема: Проблеми з оновлення PHP на Ubuntu 12.04

Дано:
VPS на якій ubuntu 12.04
Apache 2.2
PHP 5.3
IspManagers 4...

Це все встановлено за шаблоном з адмінки керування VPS

Вирішив проапдайтити PHP до 5.5 (хотів до 5.6 але не знайшов притомних інструкцій)
Маю базові навики роботи з nix системами, коротше створив собі юзера, дав йому права у visudo
Почав оновлювати за інструкцією:
http://askubuntu.com/questions/109404/h … 544#109544

Але тупо злітає сервер.
Точніше PHP воно оновлює нормально. Але валиться Apache (перестає бачити PHP).
Пробую заапдейтити здається apache2_libphp5, воно пише що апдейт потребує apache >= 2.4 (у мене 2.2)
Щось лізу в апдейт апачу, але так нічого і не виходить
Коротше щось заходжу занадто далеко від вище згаданої інструкції і чим далі тим гірше. Пробував декілька раз з нуля результат той самий.

Може хтось вже таке робив, поділіться, будь ласка, досвідом

П.С. панель IspManagers 4 не має можливості встановлення PHP вище 5.3

2

Re: Проблеми з оновлення PHP на Ubuntu 12.04

Ви оновлюєте апач, щоб він побачив PHP? Дивно, а я думав, що треба підключати PHP в конфіг-файлі апача...

3

Re: Проблеми з оновлення PHP на Ubuntu 12.04

Згідно інструкції все має бути прікольно і красиво, але у житті по-іншому
Так PHP у мене з коробки прописаний у налаштуваннях Apache

4

Re: Проблеми з оновлення PHP на Ubuntu 12.04

ailkiv написав:

PHP у мене з коробки прописаний у налаштуваннях Apache

Ви хоч заглядали у конфіг файли апача? Дивились що саме записано в ньому? Не думаю, що там підключені всі можливі версії PHP

5

Re: Проблеми з оновлення PHP на Ubuntu 12.04

ІМХО проблема може бути в тому, що IspManagers 4 давно не підтримується, на оф форумі пропонують оновитись до 5-ки.