1

Тема: Flask

Допоможіть розібратися з флеском. Я його встановлювала, але коли імпортую - помилка.

2 Востаннє редагувалося ping (27.12.2016 17:21:02)

Re: Flask

ну і як вгадати - в чому ви його імпортуєте, яка помилка?

зазвичай такі речі краще ставити під virtualenv , адже може бути питання, що до Flask вам треба PIL, а до Django - Pillow (наприклад)

тому краще на окремий проект робити окреме середовище і в ньому ставити пакети , які потрібно.
п.с.
чи може у вас неприведи_осподи ще і  якийсь віндовз замість debian стоїть?
п.п.с.
тут ключове слово -  "Я його встановлювала"
а він встановився?
перевірте через pip

vch@bb:~/PyDev$ source flask-env/bin/activate
(flask-env)vch@bb:~/PyDev$ pip freeze | grep Flask
Flask==0.11.1
Flask-Admin==1.4.2
Flask-Bootstrap==3.3.6.0
Flask-DebugToolbar==0.10.0
Flask-HTTPAuth==3.1.2
Flask-Migrate==1.8.1
Flask-SQLAlchemy==2.1
Flask-Script==2.0.5
Flask-Uploads==0.2.1
Flask-WTF==0.12
(flask-env)vch@bb:~/PyDev$
(flask-env)vch@bb:~/PyDev$ pip show Flask
---
Name: Flask
Version: 0.11.1
Location: /home/vch/PyDev/flask-env/lib/python3.4/site-packages
Requires: Jinja2, itsdangerous, Werkzeug, click
(flask-env)vch@bb:~/PyDev$

First, solve the problem. Then, write the code. (c)JJ

3 Востаннє редагувалося P.Y. (27.12.2016 18:20:48)

Re: Flask

Не знаю, в чому претензії до віндовз — pip до лінукса не прив'язаний, і фласк також.
Давайте уточнимо, як ви встановлювали фласк, і як саме його імпортували (можливо, він взагалі не встановився, або при імпорті десь літеру переплутали, і т.д.).

Ще може бути проблема, якщо на комп'ютері паралельно встановлено декілька версій python, і фласк встановлено під одною версією, а програма, що його імпортує, запускається в іншій.

Якщо у вас windows, запустіть командний рядок і введіть

py -3 -m pip list

Буде виведено список усіх пакетів, що були встановлені в python3 на цьому комп'ютері. (Якщо встановлено лише одну версію python, -3 можна опустити; замість 3 можна вказати 2, якщо встановлено python2, або повну версію, напр., 3.5 чи 2.7; якщо встановлено декілька версій, то без цього параметра буде виведено інформацію для версії за замовчуванням на цьому компі). Переконайтеся, що в виведеному списку є Flask.

py -3 -m pip install git+https://github.com/snoack/python-goto
∩⍴○⌈⍴⍺/∧\∨/⊢○ ⌿⍀⍴⌊

4

Re: Flask

P.Y. написав:

Не знаю, в чому претензії до віндовз — pip до лінукса не прив'язаний, і фласк також.
.

це жарт :)

але, не знаючи середовища , в якому імпортують flask - важко вгадати - в чому проблема.

First, solve the problem. Then, write the code. (c)JJ

5

Re: Flask

я скріншот кидала, але він не кинувся, а з флеском я вже розібралася і все працює