1

Тема: import не працює

Я зробив модуля

/scripts/auth/github.js
export class GithubAuth extends Promise {
    consturctor(){
        this.provider = new firebase.auth.GithubAuthProvider();
        this.thenable = firebase.auth().signInWithPopup(provider);
    }
    then(success, error) {
        return this.thenable(success, error);
    }
    catch(error) {
        return this.thenable(error);
    }
}

І тепер хочу імпортувати його в файлі

/scripts/app.js
import {GithubAuth} from './auth/github'

А воно не хоче імпортуватись і пише в консолі про помилку

app.js:1 Uncaught SyntaxError: Unexpected token import

Що я роблю не так?

All you want is a dingle,
What you envy's a schwang,
A thing through which you can tinkle,
Or play with, or simply let hang...

2

Re: import не працює

В якій консолі? Браузера? Браузери ще не розуміють такі останні версії JS які мають імпорт. Тому їм треба скомпілювати JS в старіший JS, наприклад за допомогою https://babeljs.io/

Подякували: FakiNyan, leofun01, ostap34PHP3

3

Re: import не працює

Або можна якісь експериментальні опції спробувати: https://jakearchibald.com/2017/es-modules-in-browsers/ Але я ще не пробував

Подякували: FakiNyan, 221VOLT, leofun013

4

Re: import не працює

ага, я вже пойняв
то я в книжці по ES6 за 2016 рік вичитав про імпорти, то думав, що воно вже працює і юзається всіма

це я хтів структурувати angulasJS аплікейшон, але потім подумав, що там же є спеціальна хвіча - сервіси, от буду їх юзати

All you want is a dingle,
What you envy's a schwang,
A thing through which you can tinkle,
Or play with, or simply let hang...
Подякували: 0xDADA11C71

5

Re: import не працює

FakiNyan написав:

ага, я вже пойняв
то я в книжці по ES6 за 2016 рік вичитав про імпорти, то думав, що воно вже працює і юзається всіма

це я хтів структурувати angulasJS аплікейшон, але потім подумав, що там же є спеціальна хвіча - сервіси, от буду їх юзати

До речі, angularjs + es6 (import, async/await, class etc) + components (angularjs 1.5+) виглядає дуже юзабельно. Можу підкинути сетап з бабелом і вебпаком.

Подякували: FakiNyan1

6 Востаннє редагувалося FakiNyan (17.10.2017 20:33:14)

Re: import не працює

iovchynnikov написав:
FakiNyan написав:

ага, я вже пойняв
то я в книжці по ES6 за 2016 рік вичитав про імпорти, то думав, що воно вже працює і юзається всіма

це я хтів структурувати angulasJS аплікейшон, але потім подумав, що там же є спеціальна хвіча - сервіси, от буду їх юзати

До речі, angularjs + es6 (import, async/await, class etc) + components (angularjs 1.5+) виглядає дуже юзабельно. Можу підкинути сетап з бабелом і вебпаком.

буду вдячний за будь-яку інхву від прохвесіонала  *BRAVO*
а хіба async/await вже є в ES6? хіба то не ES8, а в ES6 балом правлять проміси?

All you want is a dingle,
What you envy's a schwang,
A thing through which you can tinkle,
Or play with, or simply let hang...

7 Востаннє редагувалося iovchynnikov (19.10.2017 23:46:56)

Re: import не працює

FakiNyan написав:
iovchynnikov написав:
FakiNyan написав:

ага, я вже пойняв
то я в книжці по ES6 за 2016 рік вичитав про імпорти, то думав, що воно вже працює і юзається всіма

це я хтів структурувати angulasJS аплікейшон, але потім подумав, що там же є спеціальна хвіча - сервіси, от буду їх юзати

До речі, angularjs + es6 (import, async/await, class etc) + components (angularjs 1.5+) виглядає дуже юзабельно. Можу підкинути сетап з бабелом і вебпаком.

буду вдячний за будь-яку інхву від прохвесіонала  *BRAVO*
а хіба async/await вже є в ES6? хіба то не ES8, а в ES6 балом правлять проміси?

Твоя рація. Якось не звертав уваги.

git clone https://github.com/socialedge/hermes.git
cd hermes
git checkout feature/frontend-swagger-client
git checkout d5a04bd
git filter-branch --subdirectory-filter frontend-v2

В теці hermes буде скелет додатку angularjs.

npm install
npm run serve // запускає веб сервер http://localhost:8000/

Подякували: FakiNyan, leofun012