81

Re: Двiйка за незнання математики.

проблювався з цього коду

All you want is a dingle,
What you envy's a schwang,
A thing through which you can tinkle,
Or play with, or simply let hang...

82

Re: Двiйка за незнання математики.

FakiNyan написав:

проблювався з цього коду

це ще не найгірше.
а от коли починається змішування англ і роc в одних виразах -

&НаКлиенте
Процедура ПолучитьДанные(Команда)
    //Укажем документ для выборки
    Сущность = "Document_бит_ус_ЗаказНаряд";
    //Выбираем нужные нам поля документа,в формате Json, за период в день, не помечен на удаление 
    Фильтр  = "?$select=Ref_Key,Date,Number,СуммаДокумента,Контрагент_Key,ЗаказПокупателя&$format=json;odata=nometadata&$filter=Date gt datetime'"+Формат(НачалоДня(Дата), "ДФ=yyyy-MM-ddTЧЧ:мм:сс")+"' and Date lt datetime'"+Формат(КонецДня(Дата), "ДФ=yyyy-MM-ddTЧЧ:мм:сс")+"' and DeletionMark eq false";

    //Вызываем процедуру подключения и получаем данные
    ДанныеЗаказНаряд = ПодключениеOData(Сущность, Фильтр);
    //Выход если ошибка
    Если ДанныеЗаказНаряд = Неопределено Тогда
         Возврат
    КонецЕсли;
    
    //проверка на отсутствие документов
    КоличествоСтрок = ДанныеЗаказНаряд.value.Количество();
    Если КоличествоСтрок = 0 Тогда
         Сообщить("На " + Дата + " документов НЕТ.");
         Возврат
    КонецЕсли;
    
    //Заполняем табличку на форме
    СписокДокументов.Очистить();
    Элементы.СписокДокументов.Доступность = Истина;
    
    НомерСтроки = 0;
    Для Каждого Строка Из ДанныеЗаказНаряд.value Цикл
        //Индикатор
        Состояние("Запрашиваем данные", Цел(НомерСтроки * 100 /КоличествоСтрок));
        //заполняем табличку
        ГУИД         = Строка.Ref_Key;
        ОтветМассив = СпроситьЭлементСправочника("Catalog_Контрагенты", "Description", Строка.Контрагент_Key);
        НоваяСтрока = СписокДокументов.Добавить();
        НоваяСтрока.ВремяДокумента = ДайДату(Строка.Date);
        НоваяСтрока.НомерДокумента = Строка.Number;
        НоваяСтрока.СуммаДокумента = Строка.СуммаДокумента;
        НоваяСтрока.Контрагент     = ОтветМассив.Description;
        НоваяСтрока.guid           = ГУИД;
        НоваяСтрока.НалБезНал       = НалБезнал(Строка.ЗаказПокупателя);
        НоваяСтрока.Привязка       = СпроситьДокумент(ГУИД);
        НомерСтроки = НомерСтроки + 1;
    КонецЦикла
    
КонецПроцедуры

83

Re: Двiйка за незнання математики.

http://cdn.smosh.com/sites/default/files/bloguploads/simpsons-fire.gif

All you want is a dingle,
What you envy's a schwang,
A thing through which you can tinkle,
Or play with, or simply let hang...
Подякували: 0xDADA11C7, cheappi3862

84 Востаннє редагувалося /KIT\ (25.11.2017 23:35:43)

Re: Двiйка за незнання математики.

я думав що після бейсіка на росіянській мене вже нічого не здивує...

Yml0Y29pbjoxNmVTc0NyOXJySHBTV
DlGVmZjamV5djh5ZEtHM1NuNFNaCm
RvZ2Vjb2luOkROdXhrWExCaEh6eE1
wajFwbWhSdGlKWXZvWXJRckNiQjc=
Подякували: 0xDADA11C7, leofun012

85

Re: Двiйка за незнання математики.

:D

Ви справді так думаєте?

Прихований текст
Навчаюсь вчитись, щоб навчатись.
Подякували: leofun01, Lace2