1 Востаннє редагувалося Altair8800 (13.03.2019 20:07:45)

Тема: Проблеми з установкою пакетів на Ununtu 16.04

При команді установки пакету, консоль видає:

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Повний вивід, якщо цікавить
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 apache2 : PreDepends: dpkg (>= 1.17.14)
 bash-completion : PreDepends: dpkg (>= 1.15.7.2~)
 build-essential : Depends: dpkg-dev (>= 1.17.11) but it is not going to be installed
 cups-daemon : PreDepends: dpkg (>= 1.15.7.2)
 dash : Depends: dpkg (>= 1.15.0)
 dh-strip-nondeterminism : Depends: debhelper but it is not going to be installed
 fontconfig : PreDepends: dpkg (>= 1.16.1)
 fonts-kacst : PreDepends: dpkg (>= 1.15.6~)
 fonts-kacst-one : PreDepends: dpkg (>= 1.15.6~)
 fonts-nanum : PreDepends: dpkg (>= 1.15.7.2)
 fonts-sil-abyssinica : PreDepends: dpkg (>= 1.15.6~)
 fonts-takao-pgothic : PreDepends: dpkg (>= 1.15.6~)
 gir1.2-gudev-1.0 : PreDepends: dpkg (>= 1.17.14)
 grub-pc : PreDepends: dpkg (>= 1.17.13)
 imagemagick-common : PreDepends: dpkg (>= 1.15.7.2)
 install-info : PreDepends: dpkg (>= 1.16.1)
 language-pack-en : PreDepends: dpkg (>= 1.16.1)
 language-pack-en-base : PreDepends: dpkg (>= 1.16.1)
 language-pack-gnome-en : PreDepends: dpkg (>= 1.16.1)
 language-pack-gnome-en-base : PreDepends: dpkg (>= 1.16.1)
 language-selector-common : PreDepends: dpkg (>= 1.15.7.2)
 libglib2.0-0 : PreDepends: dpkg (>= 1.17.21)
 libglib2.0-0:i386 : PreDepends: dpkg:i386 (>= 1.17.21)
 libmagickcore-6.q16-2 : PreDepends: dpkg (>= 1.17.6)
 libmagickwand-6.q16-2 : PreDepends: dpkg (>= 1.17.6)
 libmtp9 : PreDepends: dpkg (>= 1.15.7.2)
 libpaper1 : Depends: dpkg (>= 1.17.2)
 libqt5svg5 : PreDepends: dpkg (>= 1.15.6~)
 libqt5webkit5 : PreDepends: dpkg (>= 1.15.6~)
 libquvi7 : PreDepends: dpkg (>= 1.15.6)
 libreoffice-common : PreDepends: dpkg (>= 1.15.7.2~)
 libsane-common : PreDepends: dpkg (>= 1.15.7.2)
 libsmbclient : PreDepends: dpkg (>= 1.15.6~)
 libubuntugestures5 : PreDepends: dpkg (>= 1.15.6~)
 libubuntutoolkit5 : PreDepends: dpkg (>= 1.15.6~)
 libunity-gtk2-parser0 : PreDepends: dpkg (>= 1.15.7.2)
 libunity-gtk3-parser0 : PreDepends: dpkg (>= 1.15.7.2)
 libvlc5 : PreDepends: dpkg (>= 1.17.14)
 libvlccore8 : PreDepends: dpkg (>= 1.17.14)
 libwbclient0 : PreDepends: dpkg (>= 1.15.6~)
 lightdm : PreDepends: dpkg (>= 1.15.7.2)
 man-db : PreDepends: dpkg (>= 1.16.1~)
 mountall : PreDepends: dpkg (>= 1.15.7.2)
 openssh-client : Depends: dpkg (>= 1.7.0)
 pcmciautils : PreDepends: dpkg (>= 1.15.7.2)
 perl : PreDepends: dpkg (>= 1.17.17)
 perl-base : PreDepends: dpkg (>= 1.17.17)
 perl-modules-5.22 : PreDepends: dpkg (>= 1.17.17)
 pkg-config : Depends: dpkg-dev but it is not going to be installed
              Depends: libdpkg-perl but it is not going to be installed
 plainbox-provider-resource-generic : Depends: dpkg (>= 1.13)
 poppler-data : PreDepends: dpkg (>= 1.15.6~)
 popularity-contest : Depends: dpkg (>= 1.10)
                      Recommends: cron or
                                  cron-daemon
 ppa-purge : Depends: dpkg (>= 1.16.1)
 python-minimal : Depends: dpkg (>= 1.13.20)
 python3-minimal : Depends: dpkg (>= 1.13.20)
 qml-module-qtgraphicaleffects : PreDepends: dpkg (>= 1.15.6~)
 qml-module-ubuntu-components : PreDepends: dpkg (>= 1.15.6~)
 qml-module-ubuntu-layouts : PreDepends: dpkg (>= 1.15.6~)
 qml-module-ubuntu-performancemetrics : PreDepends: dpkg (>= 1.15.6~)
 qml-module-ubuntu-test : PreDepends: dpkg (>= 1.15.6~)
 sgml-base : PreDepends: dpkg (>= 1.16.4)
 ubuntu-core-launcher : PreDepends: dpkg (>= 1.15.7.2)
 ubuntu-drivers-common : PreDepends: dpkg (>= 1.15.7.2)
 ubuntu-ui-toolkit-theme : PreDepends: dpkg (>= 1.15.6~)
 udev : PreDepends: dpkg (>= 1.17.14)
 unity-gtk2-module : PreDepends: dpkg (>= 1.15.7.2)
 unity-gtk3-module : PreDepends: dpkg (>= 1.15.7.2)
 vlc : PreDepends: dpkg (>= 1.17.14)
 vlc-nox : PreDepends: dpkg (>= 1.17.14)
 vlc-plugin-fluidsynth : PreDepends: dpkg (>= 1.17.14)
 vlc-plugin-jack : PreDepends: dpkg (>= 1.17.14)
 vlc-plugin-notify : PreDepends: dpkg (>= 1.17.14)
 vlc-plugin-samba : PreDepends: dpkg (>= 1.17.14)
 vlc-plugin-sdl : PreDepends: dpkg (>= 1.17.14)
 vlc-plugin-svg : PreDepends: dpkg (>= 1.17.14)
 vlc-plugin-zvbi : PreDepends: dpkg (>= 1.17.14)
 wine-stable-amd64 : PreDepends: dpkg (>= 1.14.12ubuntu3)
 zeitgeist-core : PreDepends: dpkg (>= 1.15.7.2)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Запускаю:

sudo apt-get -f install -y

Отримую:

dpkg: warning: 'dpkg-deb' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)

В интернеті пишуть, що це проблема відсутності secure_path в файлі /etc/sudoers, але він у мене вказаний:

$ sudo grep ^Defaults /etc/sudoers
Defaults    env_reset
Defaults    mail_badpass
Defaults        secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

Тому я й прийшов спитатися поради на форумі як цю проблему вирішити :)

2

Re: Проблеми з установкою пакетів на Ununtu 16.04

Файл ./etc/sudoers чи /etc/sudoers ? Крапка - це поточна тека.

3

Re: Проблеми з установкою пакетів на Ununtu 16.04

/etc/sudoers

4

Re: Проблеми з установкою пакетів на Ununtu 16.04

Ще знайшов зробити ряд команд:

sudo touch /bin/dpkg-deb
sudo chmod +x /bin/dpkg-deb
sudo touch /bin/start-stop-daemon
sudo chmod +x /bin/start-stop-daemon

Після чого знову sudo apt-get -f install -y і ось що вивелось:

dpkg (subprocess): unable to execute split package reassembly (dpkg-split): No such file or directory
dpkg:../../src/unpack.c:123:deb_reassemble: internal error: unexpected exit status 2 from dpkg-split
E: Sub-process /usr/bin/dpkg exited unexpectedly

5

Re: Проблеми з установкою пакетів на Ununtu 16.04

Думав є якесь правильне рішення, але довелось зробити все в лоб
Я глянув які взагалі в мене є файли dpkg в /usr/bin

$ ls /usr/bin/dpkg*
/usr/bin/dpkg  /usr/bin/dpkg-log-summary

Взяв інший комп'ютер з такою ж системою і порівняв:

$ ls /usr/bin/dpkg*
/usr/bin/dpkg               /usr/bin/dpkg-checkbuilddeps  /usr/bin/dpkg-genchanges   /usr/bin/dpkg-maintscript-helper  /usr/bin/dpkg-query         /usr/bin/dpkg-source        /usr/bin/dpkg-vendor
/usr/bin/dpkg-architecture  /usr/bin/dpkg-deb             /usr/bin/dpkg-gencontrol   /usr/bin/dpkg-mergechangelogs     /usr/bin/dpkg-scanpackages  /usr/bin/dpkg-split
/usr/bin/dpkg-buildflags    /usr/bin/dpkg-distaddfile     /usr/bin/dpkg-gensymbols   /usr/bin/dpkg-name                /usr/bin/dpkg-scansources   /usr/bin/dpkg-statoverride
/usr/bin/dpkg-buildpackage  /usr/bin/dpkg-divert          /usr/bin/dpkg-log-summary  /usr/bin/dpkg-parsechangelog      /usr/bin/dpkg-shlibdeps     /usr/bin/dpkg-trigger

Скопіював файли, з рута переніс на свій комп'ютер і все запрацювало  :)

6

Re: Проблеми з установкою пакетів на Ununtu 16.04

А тепер перевстановіть пакети із цими файлами. Для контролю.