1 Востаннє редагувалося pluszz (24.11.2019 17:58:11)

Тема: Запуск додатку написаного з бібліотекою Dash під Python3

Selenium WebDriwer являється фраємворком для Python3 на ньому реалізований готовий парсер. Dash бібліотека для створення реактивних веб додатків мовою Python на нім хочу реалізувати веб інтерфейс для парсера. Винекла проблемка поза тим що на сайті проекту Dash написано

In your terminal, install several dash libraries. These libraries are under active development, so install and upgrade frequently. Python 2 and 3 are supported.

У мене додатки написані на цій бібліотеці працюють лише під Python 2, а під Python 3 в терміналі вибиває помилку

ModuleNotFoundError: No module named 'dash'

. Ось тепер питання. Що може бути не так, може хтось стикався з подібними проблемами, підкажіть як можна вирішити.

2

Re: Запуск додатку написаного з бібліотекою Dash під Python3

Нічого не знаю про Selenium та dash (принаймні такого, що б не можна було знайти за 2 хвилини гуглення), але Python 2 і Python 3 встановлюються як дві зовсім окремі програми, те, що в одному з них встановлений модуль, ніяк не впливає на інший. Встановіть цей ваш dash (чи Selenium, дивіться інструкцію на сайті проєкту) у Python 3 - і буде вам модуль dash.

3

Re: Запуск додатку написаного з бібліотекою Dash під Python3

Запрацювало!!!

koala написав:

Нічого не знаю про Selenium та dash (принаймні такого, що б не можна було знайти за 2 хвилини гуглення), але Python 2 і Python 3 встановлюються як дві зовсім окремі програми, те, що в одному з них встановлений модуль, ніяк не впливає на інший. Встановіть цей ваш dash (чи Selenium, дивіться інструкцію на сайті проєкту) у Python 3 - і буде вам модуль dash.

Dash
Plotly Dash це бібліотека для створення веб додатків на Python для ледацюг котры не знають JS і знати не хочуть(таких як я).

На офіційнім сайті інструкція по установці проста.

pip install dash==1.6.1

І в PDF туторіалі написано.

Прихований текст

1.  Mac and Linux distributions: Dash is available on both Python 2 and Python 3 distributions, and can be installed using pip.

Але я чомусь незміг установити просто через pip цю бібліотеку для Python 3 ніякими способами. Але на одному з англомовных форумів (не першої свіжості) я знайшов наступні рядки.

$ conda activate Python3
$ pip install dash dash-renderer dash-html-components dash-core-components plotly

Але оскільки в офіційному гайді написано:

Прихований текст

Note: starting with dash 0.37.0, dash automatically installs dash-renderer, dash-core-components, dash-html-components, and dash-table, using known-compatible versions of each. You need not and should not install these separately any longer, only dash itself.

о

То я зробив так :
установив anacondu(попутно подивлюсь шо то за монстер)

А потім:

$ conda activate Python3
$pip install dash==1.6.1

P.S. думаю що інсталяція з сирця буде кращим варіантом як мої танці з бубеном, тому ссилочка на git "https://github.com/plotly/dash.git"
І ссилочка на офіційний сайт проекту.https://plot.ly/dash/
Можливо ще вкогось виникнуть такі проблеми і цей комент з економить йому час та нерви.

4

Re: Запуск додатку написаного з бібліотекою Dash під Python3

Здається, без перемикання можна просто pip3 писати для Python3. Хоча може і залежати від ваших конкретних налаштувань.

5 Востаннє редагувалося pluszz (25.11.2019 13:19:33)

Re: Запуск додатку написаного з бібліотекою Dash під Python3

koala написав:

Здається, без перемикання можна просто pip3 писати для Python3. Хоча може і залежати від ваших конкретних налаштувань.

Я власне пробував і в мене не спрацювало при  pip3 install dash==1.6.1 мені в консолі вибивало що в мене встановлений остання версія а при запуску програми через python3 мені вибивало що немаэ такого модуля. Може треба було на PATH глянути? А взагалі поки я з цим бавився дуже пошкодував що перейшов з арч на убунту. (Там у мене хоча система і злітала через намагання установити шось не зрозуміле з AUR але якось то  всьо набагато ліпше працювало і настроювалося).