Тема: PHP composer

добрий день-вечір  мені  скинули сайт , щоб я доборив на php, lavarel я він скачений з гіта тому треба становити залежності 
нажимаю  установити  composer instal через комадну строку  (composer стоїт глобально ) вискакує така помилка

HP Warning: PHP Startup: Unable to load dynamic library 'php_mbstring' (tried: C:\php\php-7.4.0-Win32-vc15-x64\php_mbstring (%1 ╨╜╨╡ ╤П╨▓╨╗╤П╨╡╤В╤Б╤П ╨┐╤А╨╕╨╗╨╛╨╢╨╡╨╜╨╕╨╡╨╝ Win32.), C:\php\php-7.4.0-Win32-vc15-x64\php_php_mbstring.dll (╨Э╨╡ ╨╜╨░╨╣╨┤╨╡╨╜ ╤Г╨║╨░╨╖╨░╨╜╨╜╤Л╨╣ ╨╝╨╛╨┤╤Г╨╗╤М.)) in Unknown on line 0
Key config is a duplicate in ./composer.json at line 66
You are running Composer with SSL/TLS protection disabled.
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for erusev/parsedown 1.7.3 -> satisfiable by erusev/parsedown[1.7.3].
- erusev/parsedown 1.7.3 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
Problem 2
- Installation request for laravel/framework v6.7.0 -> satisfiable by laravel/framework[v6.7.0].
- laravel/framework v6.7.0 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
Problem 3
- Installation request for league/flysystem 1.0.61 -> satisfiable by league/flysystem[1.0.61].
- league/flysystem 1.0.61 requires ext-fileinfo * -> the requested PHP extension fileinfo is missing from your system.
Problem 4
- Installation request for facade/ignition 1.13.0 -> satisfiable by facade/ignition[1.13.0].
- facade/ignition 1.13.0 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
Problem 5
- Installation request for phpunit/phpunit 8.5.0 -> satisfiable by phpunit/phpunit[8.5.0].
- phpunit/phpunit 8.5.0 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
Problem 6
- Installation request for scrivo/highlight.php v9.15.10.0 -> satisfiable by scrivo/highlight.php[v9.15.10.0].
- scrivo/highlight.php v9.15.10.0 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
Problem 7
- laravel/framework v6.7.0 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
- facade/flare-client-php 1.3.0 requires illuminate/pipeline ~5.5|~5.6|~5.7|~5.8|^6.0 -> satisfiable by laravel/framework[v6.7.0].
- Installation request for facade/flare-client-php 1.3.0 -> satisfiable by facade/flare-client-php[1.3.0].

To enable extensions, verify that they are enabled in your .ini files:
- C:\php\php-7.4.0-Win32-vc15-x64\php.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

як я розумію він не бачить цих модулей перестановка пхп не помогла не можу вирішити цю проблему

2

Re: PHP composer

Прихований текст

Бачу, хлопчик, якому Фаріон казала про поїзд, підріс

МішаЛьвів написав:

як я розумію він не бачить цих модулей

В точку. 10 разів пише, що не бачить.

МішаЛьвів написав:

перестановка пхп не помогла

Логічно. Якщо ви приготували борщ без картоплі, то повторне готування за тим самим рецептом може додати картоплю?

Пошукайте в гуглі, як встановлювати і налаштовувати модулі в PHP, будуть ще питання - звертайтеся.

Подякували: bvn, leofun012

3

Re: PHP composer

прикол в тому , що я поставив ці модулі і доставив в php.ini , і в мене дальші ці помилки  мій пхп зараз так виглядає https://github.com/mishakorolcov1/php

4

Re: PHP composer

У вас там два mb_string.dll, в корені і в ext
І ще там підказка, що на Windows
extension_dir = "ext"
має бути.

5

Re: PHP composer

https://stackoverflow.com/questions/485 … ger-w?rq=1
Назви модулів в останніх версіях слід писати без php_... і ...dll, лише самі модулі.
extension=mbstring

Подякували: leofun01, ostap34PHP2

6

Re: PHP composer

дякою!!!  дуже допоміг , ти адмін цього форума ?

7

Re: PHP composer

МішаЛьвів написав:

дякою!!!  дуже допоміг , ти адмін цього форума ?

1. Не тикайте мені, ми з вами на брудершафт не пили.
2. Я модератор у кількох розділах. У цьому - ні.

8

Re: PHP composer

1. Я вибачаюся , я не хотів  вас обідити
2. Ще раз дякою ,що допогли , гарного вам дня