1

Тема: GitHub дискримінує користувачів за версією браузера

Сьогодні я зайшов на GitHub і в заголовку сторінки побачив

github.com написав:

https://github.githubassets.com/images/icons/ie-notice.png
Please note that GitHub no longer supports old versions of Firefox.
We recommend upgrading to the latest Safari, Google Chrome, or Firefox.
[ Ignore ]  [ Learn more ]

Прочитав, подумав "не перший раз бачу подібне", гортаю дальше, "Sign in", успішно ввійшов, і ...

github.com написав:

https://github.githubassets.com/images/spinners/octocat-spinner-64.gif
Loading activity...

висить. Точніше навіть не намагається підтягувати дані.

В мене Firefox Quantum Extended Support Release 60.9.0esr.

Як змусити мого бро відправляти іншу версію (наприклад 68.4.1esr) в заголовках HTTP запиту ?

Подякували: ostap34PHP, 221VOLT2

2

Re: GitHub дискримінує користувачів за версією браузера

так файрфокс же ж з відкритим кодом, нє? то може можна то прямо в коді змінити і зкомпіляти?

Подякували: leofun011

3 Востаннє редагувалося koala (17.01.2020 16:59:38)

Re: GitHub дискримінує користувачів за версією браузера

Для початку - це не дискримінація. Це відсутність підтримки. Зрештою, Mozilla теж не гарантує роботу вашої версії РудоїПанди.
Ну і зайдіть на

about:config

і пошукайте там по слову useragent. Якщо не знайде - ніби треба створити поле типу String

general.useragent.overridepreference

і ввести туди щось на кшталт

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.13; ko; rv:1.9.1b2) Gecko/20081201 Firefox/60.0

Стрічки UserAgent:

Ну або пошукайте розширення для вашої підстаркуватої пандочки, їх була купа. Знову ж по слову UserAgent.

Подякували: FakiNyan, leofun01, ostap34PHP, 221VOLT4

4

Re: GitHub дискримінує користувачів за версією браузера

FakiNyan написав:

так файрфокс же ж з відкритим кодом, нє? то може можна то прямо в коді змінити і зкомпіляти?

Можна, але тоді питань буде трохи більше, та й нащо, якщо воно є в налаштуваннях?

Подякували: FakiNyan, leofun01, ostap34PHP3

5

Re: GitHub дискримінує користувачів за версією браузера

А чому б просто не оновитися?

Подякували: leofun01, wander, ostap34PHP3

6 Востаннє редагувалося wander (17.01.2020 17:44:02)

Re: GitHub дискримінує користувачів за версією браузера

Схоже на релігійні забобони?) Страх перед будь-якими оновленнями :)
У мене є знайомий, який сидить виключно на якійсь доісторичній версії браузера pale moon, настільки старій, що веб версія slack'y його навіть не впускала, як думаєте, що він зробив?
Скачав інший браузер?
Ні, звісно ж обманув slack'y, щоб зайти з того браузера :)
Не те, щоб це щось погане, але що тепер винити розробників веб версії slack'и, бо вони, гади такі, дискримінують користувачів за версією браузера?

Подякували: leofun011

7

Re: GitHub дискримінує користувачів за версією браузера

Якщо щось працює не так гарно як задумав дизайнер сайту - це одне. А тупо тебе не пускати, бо інша версія, то це друге.

Подякували: leofun011

8

Re: GitHub дискримінує користувачів за версією браузера

FakiNyan написав:

так файрфокс же ж з відкритим кодом, нє? то може можна то прямо в коді змінити і зкомпіляти?

Так би і зробив, якщо б ви показали мені рядки коду у файлах, де саме потрібно змінювати.
Ось архіви сурсів.

koala написав:

Для початку - це не дискримінація. Це відсутність підтримки.

Ні, не можу з вами погодитись. Відсутністю підтримки це було би у випадку, якщо нова версія бро використовує технологію несумісну зі старою версією. А тут маємо не значні зміни в версіях бро і GitHub відмовився працювати з "інакомислячими". Мені не ясно, для чого взагалі перевіряти версію бро ...

koala написав:
about:config
general.useragent.overridepreference

О, корисна інфо. За це дякую.
Поредагував, замінив всі 60.9.0 на 68.4.1, покищо не помогло.
Відкрив реєстр ос, попробую ще там переписати і відзвітую.

koala написав:

А чому б просто не оновитися?

Тому що з кожним оновленням розробники не тільки щось додають а і щось видаляють. Я вже мав Firefox'и 7x.x.x, не сподобалось. А без оновлень в мене є прекрасно налаштована система і є велика ймовірність що оновлення зробить її тільки гіршою.

adziri написав:

Схоже на релігійні забобони?) Страх перед будь-якими оновленнями :)

Так і є.

adziri написав:

У мене є знайомий, який сидить виключно на якійсь доісторичній версії браузера pale moon, настільки старій, що веб версія slack'y його навіть не впускала, як думаєте, що він зробив?
Скачав інший браузер?
Ні, звісно ж обманув slack'y, щоб зайти з того браузера :)

Красавчик.

adziri написав:

Не те, щоб це щось погане, але що тепер винити розробників веб версії slack'и, бо вони, гади такі, дискримінують користувачів за версією браузера?

Так.

Подякували: 221VOLT1

9 Востаннє редагувалося FakiNyan (17.01.2020 20:27:15)

Re: GitHub дискримінує користувачів за версією браузера

осьо
https://cdn.discordapp.com/attachments/333936584481177600/667797061877628958/unknown.png

Подякували: leofun01, 221VOLT2

10

Re: GitHub дискримінує користувачів за версією браузера

Поредагував:

  • налаштування браузера (about:config)

  • файли в директорії програми (%ProgramFiles(x86)%\Mozilla Firefox\*.ini)

  • реєстр ОС (regedit.exe -> HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla Firefox ESR\CurrentVersion)

Поміняти версію не вдалося.

На GitHub поки буду заходити з Opera 62.0.

Подякували: 221VOLT1

11

Re: GitHub дискримінує користувачів за версією браузера

Порішав проблему, сподіваюсь що не створив нову :

  1. Завантажив і встановив версію 68.4.1esr на віртуальну машину

  2. Перетягнув папку інстальованого бро з віртуалки на основний хост (замінив існуючі файли)

  3. Відкрив налаштування, відключив деякі можливості (відбиток браузера, багатопроцесовість, блокування небезпечного вмісту, авто оновлення)

  4. Відкрив about:config і повідключав все що вважав за непотрібне

  5. Перезапустив бро, покищо все працює як треба

Подякували: 221VOLT1

12

Re: GitHub дискримінує користувачів за версією браузера

Тобто фактично оновилися до 68ESR і щось підкрутили в конфігурації?

Подякували: leofun01, 221VOLT2

13

Re: GitHub дискримінує користувачів за версією браузера

Так. Все одно ВогоньЛис зручніший за Оперу.

Подякували: pluszz, 221VOLT2

14

Re: GitHub дискримінує користувачів за версією браузера

Чому б не користуватися Pale moon? Є збріки для Windows XP.

Не те, щоб це щось погане, але що тепер винити розробників веб версії slack'и, бо вони, гади такі, дискримінують користувачів за версією браузера?

Так, винити їх.

Подякували: leofun011

15 Востаннє редагувалося wander (18.01.2020 16:31:44)

Re: GitHub дискримінує користувачів за версією браузера

Так, винити їх.

І за що? Бо вони забороняють різні екзотичні браузери? Функціональність яких ще під питанням, як і безпека?
Зрештою, бувають різні вимоги до браузерів, які підтримуються. Далеко не завжди розробники можуть якось вплинути на список підтримуваних браузерів. Заборона тих чи інших браузерів та їх версій може бути цілком виправданою, бувають різні ситуації, інколи, буває таке, що у ході експлуатації чи тестування знаходяться версії браузерів, які щось ламають. У мене на проєкті був такий випадок.

Десь зо півроку тому, прилетів тікет, що така-то версія ВогняноїЛисиці поламала частину функціоналу рендера, який працює на WebGL. Виявилося, що в цій версії браузера була поламана якась ф-я з WebGL, точно уже не згадаю яка, бо цю історію розказував тіммейт, він з веб команди. Згодом вході тестування було виявлено ще декілька версій (правда вже більш старіших), які теж щось ламали.

16

Re: GitHub дискримінує користувачів за версією браузера

adziri написав:

Так, винити їх.

І за що? Бо вони забороняють різні екзотичні браузери? Функціональність яких ще під питанням, як і безпека?

Це проблема і відповідальність користувача, а не сайту. Сайт має максимум попереджати про можливі проблеми, але не створювати їх. Якщо завтра вийде суперкрутий браузер, що підтримуватиме всі потрібні сайтам можливості, але сайти його блокуватимуть, бо не знатимуть його UserAgent - це буде провина сайту, а не браузеру.

adziri написав:

Зрештою, бувають різні вимоги до браузерів, які підтримуються. Далеко не завжди розробники можуть якось вплинути на список підтримуваних браузерів. Заборона тих чи інших браузерів та їх версій може бути цілком виправданою, бувають різні ситуації, інколи, буває таке, що у ході експлуатації чи тестування знаходяться версії браузерів, які щось ламають. У мене на проєкті був такий випадок.

Десь зо півроку тому, прилетів тікет, що така-то версія ВогняноїЛисиці поламала частину функціоналу рендера, який працює на WebGL. Виявилося, що в цій версії браузера була поламана якась ф-я з WebGL, точно уже не згадаю яка, бо цю історію розказував тіммейт, він з веб команди. Згодом вході тестування було виявлено ще декілька версій (правда вже більш старіших), які теж щось ламали.

Ще раз: якщо сайт не відкривається, бо браузер не підтримує певні функції - це нормально. Якщо сайт не відкривається, бо сайт виявляє версію браузера і видає йому неправильну інформацію - це погано.
Утім, тут більше схоже на першу ситуацію. Сайт підтримує всі популярні браузери, які мають працювати за заявами їхніх розробників. 60ESR вже не підтримується, 68ESR підтримується, і схоже, що проблема саме в браузері.

Подякували: wander, leofun012

17

Re: GitHub дискримінує користувачів за версією браузера

Тобто простим wget вже нічого з сайту взяти не получиться? Треба буде вгадувати, які хедери посилати?

Подякували: koala, leofun012

18 Востаннє редагувалося wander (18.01.2020 20:11:20)

Re: GitHub дискримінує користувачів за версією браузера

koala написав:

Це проблема і відповідальність користувача, а не сайту. Сайт має максимум попереджати про можливі проблеми, але не створювати їх.

Повністю підтримую.

koala написав:

Якщо завтра вийде суперкрутий браузер, що підтримуватиме всі потрібні сайтам можливості, але сайти його блокуватимуть, бо не знатимуть його UserAgent - це буде провина сайту, а не браузеру.

Ну, якщо суперкрутий та популярний, то я думаю, що його UserAgent швидко внесуть в список підтримуваних, це буде лише справа часу, ну і звісно бюрократії )

koala написав:

Якщо сайт не відкривається, бо сайт виявляє версію браузера і видає йому неправильну інформацію - це погано.

Гм, ну, так, тоді вже варто задумуватися про дискримінацію :D

koala написав:

Утім, тут більше схоже на першу ситуацію. Сайт підтримує всі популярні браузери, які мають працювати за заявами їхніх розробників. 60ESR вже не підтримується, 68ESR підтримується, і схоже, що проблема саме в браузері.

Тоді не бачу проблем, щоб не оновитися.

19

Re: GitHub дискримінує користувачів за версією браузера

Vo_Vik написав:

Тобто простим wget вже нічого з сайту взяти не получиться? Треба буде вгадувати, які хедери посилати?

Вітаю в світі React та динамічних сторінок.

20

Re: GitHub дискримінує користувачів за версією браузера

Ще раз динамічна сторінка це ок. Перевірити хедер і якщо знаєш, що щось з твого дефолтного коду не працює в ІЕ, то запускаєш на ІЕ інший js. Але якщо не впізнав хедер, то даєш, хоть щось, а не кажеш ідіть нафіг, я вас не знаю.

Подякували: leofun011