1

Тема: Arch завис, і тільки звуки були

Вітаю.
Сиджу я на своєму арчі, працюю, і тут він бере і зависає, останнє, що я помітив, це пам'ять завантажена на 99%, проц на 80+%, і температура до 50C.
Воно лише показувало картинку статичну і було чути музику, бо вона грала в браузері, і ні на які натиски кніпок не відповідало, довелось перезавантажувати.

Чому таке могло статись, або як перевірити, чому воно сталось?

2

Re: Arch завис, і тільки звуки були

12309?

Подякували: leofun011

3

Re: Arch завис, і тільки звуки були

koala написав:

12309?

То ж я вас питаю. Я нічого особливого не робив такого, все, як завжди, і ніяких проблем не було, навіть лагів не було. Теоретично може бути, що я одночасно багато всього почав робити, і щось сталось, але як то перевірити - я не наю.
Як то перевірити?

4

Re: Arch завис, і тільки звуки були

ну, це  може бути одна з "переваг" rolling release

можна спробувати поритися в логах - там по ідеї є якийсь syslog і глянути туди

p.s.
зрештою, якщо Ви не системний програміст на Linux, то краще плавно звикатися з думкою про міграцію на стабільний debian

5

Re: Arch завис, і тільки звуки були

в мене lts

6

Re: Arch завис, і тільки звуки були

Може Ви попали на сайт браузерного майнингу? Тобто на сайт, на якому встановлений js-майнер. зазвичай він є на сайтах з тематикою "новини, політика", рідше - на сайтах для програмістів. Бо я сам встановив собі самому js-майнер на сайт на безкоштовному хостингу, сам на цьому сайті сидів майнив, поки комп не вирубився. Зараз комп не врубається. Мать зіпсувалася. При запуску "Memory runs is single channel" і на цьому висить, потім видає "INSERT DISK AND PRESS ENTER". Так що обережно.
Дуже схоже. Ви говорите, у вас браузер був відкритий, 50 градусів, 88%. А пам'ять використовується для зберігання кешів.

7

Re: Arch завис, і тільки звуки були

Ukrvital написав:

Може Ви попали на сайт браузерного майнингу? Тобто на сайт, на якому встановлений js-майнер. зазвичай він є на сайтах з тематикою "новини, політика", рідше - на сайтах для програмістів. Бо я сам встановив собі самому js-майнер на сайт на безкоштовному хостингу, сам на цьому сайті сидів майнив, поки комп не вирубився. Зараз комп не врубається. Мать зіпсувалася. При запуску "Memory runs is single channel" і на цьому висить, потім видає "INSERT DISK AND PRESS ENTER". Так що обережно.
Дуже схоже. Ви говорите, у вас браузер був відкритий, 50 градусів, 88%. А пам'ять використовується для зберігання кешів.

та ні, я лише на певних сайтах ходю постійно, нічого нового не було

8

Re: Arch завис, і тільки звуки були

FakiNyan написав:

та ні, я лише на певних сайтах ходю постійно, нічого нового не було

Це нічого не гарантує. Перенаправлення можуть бути вбудовані в банери.

9

Re: Arch завис, і тільки звуки були

koala написав:
FakiNyan написав:

та ні, я лише на певних сайтах ходю постійно, нічого нового не було

Це нічого не гарантує. Перенаправлення можуть бути вбудовані в банери.

то як перевірити? якісь логи мо де є? бо я гуглив, але щось не міг нічого надибати корисного

10

Re: Arch завис, і тільки звуки були

Насправді навряд чи було саме таке, але ймовірність є. Ну і гляньте, що в цей час в
/var/log/messages
/var/log/syslog
/var/log/user.log
/var/log/kern.log
/var/log/boot
писалося. Може, якийсь натяк знайдете.

11

Re: Arch завис, і тільки звуки були

в мене в /var/log тілько таке є
https://i.imgur.com/JGVA8aL.png

12

Re: Arch завис, і тільки звуки були

FakiNyan написав:

в мене в /var/log тілько таке є
https://i.imgur.com/JGVA8aL.png

ну в різних версіях лінуксів то може по різному називатися.

13 Востаннє редагувалося reverse2500 (22.02.2019 18:32:08)

Re: Arch завис, і тільки звуки були

шось дуже багато логів Xorg

$ cat Xorg.0.log | grep EE 

шо виводить ?
тут короче хоч бери і всюди дивись, навіть може бути що немає swap файлу, або він був, шось обновилось і відключився. В мен і таке було

Подякували: FakiNyan1

14

Re: Arch завис, і тільки звуки були

cat /var/log/Xorg.0.log | grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     4.667] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     4.667] (EE) Failed to load module "vesa" (module does not exist, 0)
[     4.738] (II) Initializing extension MIT-SCREEN-SAVER
[     5.620] (EE) libinput: TPPS/2 Elan TrackPoint: Failed to create a device for /dev/input/mouse1
[     5.620] (EE) PreInit returned 2 for "TPPS/2 Elan TrackPoint"